I'm running the DOORS client and server on a single machine. I've recently installed DOORS Web Access server on the same machine. DOORS Web Access works fine. I modified the doorsRedirector.properties file to use the http://servername:8080/dwa url prefix. However, trying to use the URLs indicates a redirection loop. This is what I get from a Chrome browser: This webpage has a redirect loop
The webpage athttp://my_actual_server_name:8080/dwa/rm/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/null/doors/redirector/?urn=urn:rational::1-5151f5ff38ff10df-O-102-000001c3 has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.
I've configured the doors server using dbadmin as shown in the setup instructions, also configuring the festival.xml file as directed (files attached) I'd like to revert back to using doors:// prefix, but I can't find any way to make that happen. I think this will resolve my redirection issues. If there's a way to keep the http prefix and resolve the redirection loop, that's also ok. Any help would be greatly appreciated, Abe
Update: I've learned how to revert back to "doors://..." URLs. It appears that my DCN settings are not working properly as the "dbadmin -dcnInit" commad replies "Failed to initialise Data Change Notifications." The -dcnInfo command replies "Data Change Notifications enabled but not sending"
abe777 - Tue Jun 25 13:43:26 EDT 2013 |
Re: DOORS URL Redirection Loop 1. Set the dwa.url.prefixvalue to the values you entered for -dwaProtocol, -dwaHost, and -dwaPortin the dbadmincommand in Configuring the Rational DOORS database server.
Important:The value of -dwaHost must be the fully qualified hostname of the computer
- Please goto Doors and look into URL of Doorsdatabase properties it should contain http:// not doors://
Let us know URL in Doors properties |
Re: DOORS URL Redirection Loop MohanRS - Tue Oct 01 07:52:34 EDT 2013 1. Set the dwa.url.prefixvalue to the values you entered for -dwaProtocol, -dwaHost, and -dwaPortin the dbadmincommand in Configuring the Rational DOORS database server.
Important:The value of -dwaHost must be the fully qualified hostname of the computer
- Please goto Doors and look into URL of Doorsdatabase properties it should contain http:// not doors://
Let us know URL in Doors properties
Hi Mohan,
cash-benefit http://hostname/wps/$1/retail- banking/insurance/hospital- cash-benefit [L,R=301] This webpage has a redirect loop "
http://hostname/wps/portal/ retail-banking/retail-banking/ retail-banking/retail-banking/ retail-banking/retail-banking/ retail-banking/retail-banking/ retail-banking/retail-banking/ retail-banking/retail-banking/ retail-banking/retail-banking/ retail-banking/retail-banking/ retail-banking/retail-banking/ retail-banking/retail-banking/ retail-banking/insurance/ hospital-cash-benefit
the output is like this i don't know why am getting this loop error and I cleared all caches history every thing in browser but still error exits am unable to get out from this issue please help me |